Device Details Detected:
Spider - Spider / Other / CCBot 2.0

Are your other devices supported?


Snuza Connect App Bluetooth Minimum Device Requirements:

The Snuza Connect App can be installed on an Android or iOS device.
Devices must meet the following minimum requirements:

Android Requirements:

5.0 OS or later

Android version 5.0 also known as Android Lollipop was released in November 2014. Most devices manufactured after this date will likely have this version or a newer version installed. The Android mobile operating system is used by many different manufacturers across the world. Snuza makes a concerted effort to ensure full compatibility with most popular mobile devices.


Apple iOS Requirements:

iOS 11.0 or later

Compatible with iPhone, iPad, iPod touch


The following phone models did not pass our internal tests with some of our devices. All Xiaomi and Huawei phones should not be used.
The phone and device may work together, but may require regular Snuza Connect App Bluetooth Troubleshooting.

  • Samsung A8
  • Samsung A20
  • Samsung A40
  • Huawei P8 Lite
  • Huawei P9 lite
  • Xiaomi Mi A2
  • Xiaomi Mi 9 SE
  • Xiaomi Mi A1
  • Huawei Phones
  • Lenovo S960 VIBEX
  • Meizu mx4
  • Samsung J3 Model J320FN

NOTES:
Phones that feature an Android (Go edition) operating system will list the Snuza Connect App as incompatible in the Play Store.
This version of Android has limitations resulting in certain features not working with the Snuza Connect App.